NMRFAM-SPARKY Quick Tutorial
Macro Methods

Now that you have processed the 2D spectra for both Nb6 and mNb6 in complex with Spike
RBD, it’s time to begin comparing spectra and gain insights into the dynamic behavior of the
nanobodies how they interact with the RBD. We will use Sparky for the data analysis since it has
a multitude of useful functions and is generally more convenient to use than NMRPipe. Sparky
was originally created by Tom Goddard and Tom Ferrin at UCSF and is currently maintained by
the NMRFAM at the University of Wisconsin. Sparky is under constant development and this
tutorial is by no means exhaustive of its capabilities. The aim of this tutorial is to familiarize you
with some of the basic features you need to examine spectra and begin generating useful
information for determining chemical shift perturbations.

In addition to buttons and menus, Sparky utilizes a number of two-letter commands that allow
you to easily manipulate spectra and a complete list of these commands can be accessed by
typing hl. The Sparky manual itself can be accessed by typing he and provides information
about some of the program’s features. In the instructions that follow, I will frequently refer to the
two-letter codes since they are easier to implement but I have also included instructions for
accessing some of the features from the drop-down menu.

1. Open NMRFAM-SPARKY from the applications folder. If this is the first time opening
Sparky, you will be prompted to allow the program to create data directories (Save, Lists,
Projects).

X/ Question

When you open a file Sparky starts by showing you
the contents of the Save or Projects or Lists
subdirectory in

JUsers/rwtibble/Sparky

These directories don't all exist.
Would you like to create the missing directories?

(You can specify a different default directory by
setting the SPARKYHOME environment variable before
starting the program.)

)

Yes ‘ No |
I recommend setting SPARKYHOME to be in your nmrdata directory, which is likely not the
default location, so click NO on the pop-up window. You can change the location of these
folders later by selecting NMRFAM -> Utilities -> Change SPARKYHOME. After setting
SPARKYHOME, you'll need to restart Sparky.

%/ Select a directory to set as SPARKYHOME
Directory:  /Users/rwtibble/nmr = |

£1 2D_NUS_example
1/€1 2021_Macro_Methods_NMR
£7 20210302_Nb6_RBD

£ 20210303_mNb6_RBD [@ \| SPARKYHOME
SPARKYHOME has been changed. Please
(e ] restart the program.
| Selection: |/Users/rwtibble/nmr oK

Cancel |

2. Now that Sparky has created the necessary directories, we need to provide a list of NH
assignments we can read onto the spectrum later. This file, Nb6_nhsqc.list, is also in the Box
Folder you downloaded. Move it into the Lists folder.

> [l 2021_Macro_Methods_NMR
» [l 20210302_Nb6_RBD
» [l 20210303_mNb6_RBD
v [ Lists
R Nb6_hsqc.list

B nmrfam_news
» [ Projects
> [ save
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3. Open the NHSQC spectrum for Nbb6: fo or File -> Open and select the processed .ft2 file in the
Nbé_nhsqc directory.

QOpen File
Directory:  /Users/rwtibble/nmr = ‘ Open File
£ 2D_NUS_example £] save Directory:  /Users/rwtibble/nmr/2021_Macro_Methods NMR/Nb6/Nb6_nhsqc
&1 2021_Macro_Methods_NMR El .DS_Store £7 pdata B audita.txt Bl gpnaml Bl pulseprogram
21 20210302_Nb6_RBD El nmrfam_news Bl acqu El cpdprg3 Bl gpnam2 B scon2
(21 20210303_mNb6_RBD El acqu2 E EA El gpnam3 El ser
£ Lists El acqu2s El fid.com El Nbé_nhsqc.ft2 El shimvalues
1 Projects El acqus El format.ased El Nb6_nhsqc.ucsf [El specpar
El adcinfo_TRX1.xml El format.temp El nhsgc.com El spnaml [
4 I £
] [ [ O
File pame: Open File name: Nb6_nhsqc.ft2 Open
Files of type: Any (*) = ‘ cancel | Files of type:  Any (¥) —| cancel |
1

Note: The default Sparky format is .ucsf, which is automatically generated upon opening the .ft2
file for the first time (Nb6_nhsqc.ucsf).

X| Nb6_nhsqc -- selected |
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4. Type ct (View->More->Contour Levels) to open pT——
. ontour Levels Nb6_nhsqc
the contour window. Change the values to those View: nbg_nhsqe —
shown at right and click Apply. You may also change | lowest  Levels  Factor  Color
the color of the spectrum from the drop-down menu o5 s=f0 =2 [£40 ]
. . . Negative |-3.85e+10 [0 [1.40 green —
in this window. ,
Ok ‘ Apply ‘ Close Help
A few words for navigating around a spectrum: T
Take a moment to look at the Pointer Mode (pm) window. It should Lt .
currently be in Zoom Mode. Click and form a box to zoom on the region |- Zfemeben =
from ~8.5-9.5 ppm in the hydrogen dimension and ~120-125 ppm in the b e
nitrogen dimension. Use the arrow keys to move around the spectrum b
while maintaining the same window view. You can type zi or zo to zoom | inteorste .
in or out, respectively. A couple of particularly useful commands are zp, b
which restores the previous view, and zf, which will return to the full ® S VTIENE (UG5S diel

spectrum view.
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Now we will read in the resonance assignments and display them on the spectrum.

5. Return to a view of the full spectrum by typing zf and type rp ° X Reagposicist ‘ -
to open the Read Peak List window (Extensions -> Peak ->Read s s mac - ,
peak hSt. Unreadable lines L|
6. Click Browse and navigate to your List directory and click

Nb6_nhsqc.list Z
7. Click Create Peaks and the spectrum should be populated o dtec .

with assignments for the NTD. - - -

N tol.:0.35 ,Ctol.:0.35 |, H tol.:|0.025

8. Type Ic and then lu to center the labels and then uncover them from Omament Siz

Spectrum: Npg nhsqc

one another. The label sizes is likely quite small and hard to read. YOu  |omament sizes in wi ppm units
can change the properties by typing 0z and changing the values in the =~ ['2°=!==e 02

Peak size: |0.07

pop-up window. Peak group size: [0.055
Line thickness: |0.02
[:

ok Apply Close

9. Display the peak list by typing It (Peak -> Peak List...). It has three columns: (1) Assignment
(2) Nitrogen chemical shift and (3) Hydrogen chemical shift. Double-clicking on an entry centers
the spectrum on that peak.

pectrum Peaks Nb6_nhsq
Assignment wl w2
V2N-H 120.471 7.834
Q3N-H 124.958 8.384
L4N-H 125.789 8.224
V5N-H 121.009 8.468
EBN-H 131.505 9.403
STN-H 114.981 9.442
G8N-H 107.589 8.622
GON-H 106.545 7.711
Search for: 0/102 (102)
Update | save... ‘ Options... | Close | Help

10. Navigate around the spectrum (or click on each entry in the peak list) and note if there are
any peak labels that appear to be off-centered from the resonance. Enter Select mode (click the
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radio button or type fn+F1) and click on the resonance. A box will appear around the X. Type pc
and the peak should move to the center of the resonance.

xxxxx

Before continuing to adjust other peaks, save your session as a |2 feemnenenmmess
project (File -> Project/Save As or ja). I highly recommend
saving the project file regularly so you don’t lose progress (File -
> Project/Save or js).

File name: |Nb6_comparisons.proj save
In addition to saving the spectrum, we need to save the adjusted — [Z=obes w0
peak list. Between adjusting peaks, click Update in the peak list window and the corrected peaks
positions will be recorded. Then, click Save and overwrite the initial peak list. Now you will
have an accurate table of peak positions, which will be needed for calculating chemical shift
perturbations later in the course.

Cancel

Now, we’ll open the mNb6 spectrum and overlay it onto the Nb6 spectrum to see how the two
mutations affect the spectrum.

11. Open (fo, or File -> Open) the mNb6 NHSQC spectrum (mNb6_nhsqc.ft2) and adjust the
contour level (ct) as you did for the Nb6 spectrum in (4). Also, change the color of the spectrum
to something that will contrast with the Nb6 spectrum (cyan in this tutorial).

mNb6_nhsqc -- se
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12. Type ol and the spectra overlay window will appear. Change AL
the From View to mNb6_nhsqc spectrum and the Onto View to |
Nb6_nhsqc. Click add. From View: mnb6_nhsqc — "
Onto View: Npg nhsqc —
add ‘ remove Close

13. Navigate to the Nb6 spectrum and you should see the spectrum for mNb6 overlaid. You will
notice there are significant changes and they do not overlay well. There are numerous
perturbations and resonances have disappeared.

Nb6_nhsqc

2 10.5 10.0 9.5 9.0 8.5 8.0 7.5 7.0 6.5

il

| ] |
What we’ll want to do is try and note the peaks that have changed. One way of doing this is to
determine chemical shift pertrubations (CSPs). For example, zoom in on the resonance for R67.
We can see a noticeable perturbation of between Nb6 and mNbb6. In select mode, we can move
the peak from the red to the cyan peak. Note: pc will not work for centering since there is not a
peak at the cyan location in the Nb6 spectrum. If you want to be able to use pc, you’ll need to
reverse the overlay we initially did.

14. Once you’ve moved this peak, update the peak list and save it as mNb6_nhsqc list.

Directory:  /Users/rwtibble/nmr/Lists

B Nb6_hsqc.list
B Nb6_nhsqc.list

File name: mNb6_nhsqc.list Save

Files of type: Any (*) Cancel

You can continue to move around the spectrum and adjust the peak positions.



NMRFAM-SPARKY Quick Tutorial
Macro Methods

In addition to peaks that have moved, many peaks have broadened beyond detection. Take note
of these peaks because the ratio of peak intensities between two spectra is another means of
quantitating changes. Once you have finished creating a peak list for mNb6, you can integrate
the respective spectra. This part of the tutorial will walk you through integrating the Nb6
spectrum.

15. Navigate to the Nb6 spectrum and remove any overlays. Be sure the peak labels are
displayed and the contour level has been set to an appropriate cutoff so the resonances are clearly
observed.

16. Type it and a peak integration window will appear (shown at [ Integration Nb6_nhs ]
right). Change the check boxes and values in the window so it Spectrum:  Nbe_nhsqc —

matches those shown: Integration method: Gaussian fit —
v Allow peak motion?

Note: Be sure to select the proper spectrum each time ow peak 1
v Adjust linewidths?

since you can apply different settings to individual ¥ Fit baseline?
spectra. [~ Subtract off fit peaks?
. [” Use data above lowest contour?
17. Click Apply v Use data within rectangle?
v Group peaks in contour boundary?
v Group close peaks?

w1l 15N w2 1H

—_— Max motion (ppm) |0.010 |0.010

Pointer Mode . . . - a -
c select s 18. Navigate to the Pointer Mode window and e cLRILE N 2D |2
" center F2 . . . Linewidth max (Hz) (80 80
Caddgridboth £ switch to integrate (hold the function key and Groliping|ranga (Fz) [EoNN] SOOI
( r.
- :dd gr;d \,::i F5 type FlO) Maximum minimization steps |10000
* add label F6 Minimization tolerance (%) W
2?:1“1}::: T :; Gaussian-to-Voigt mixing (%) |50
+ integrate F10 /
" zoom F11 Ok ‘ Apply ‘ Close ‘ Help ‘

" duplicate & zoom F12
" assignment copy sh-F1
" assignment guess sh-I

19. Click and draw a box around the peaks you would like to integrate.
Once you release the mouse, Sparky will begin calculating the volume.
This may take a few minutes to complete but you can tell when the
integration is done when a circle replaces the sqaure the peak (as shown
in the screenshot for S63N-H). I have found trying to integrate many
peaks at one time can cause Sparky to crash, so I suggest integrating
subsets of peaks and routinely saving your project.

20. In order to record the peak volumes, display the peak list by typing It and click Options. A
separate window will appear with a variety of variables to include in the peak list. Check the box
next to Volume and click Apply.
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® O ® X Spectrum Peaks Nb6_nhsqc
Assignment wl w2
G15N-H 112.982 9.632
G16N-H 109.147 8.382
S17N-H 109.773 7.811
L18N-H 124.783 7.339
R19N-H 122.241 9.563
L26N-H 125.958 8.709
S21N-H 125.645 7.832

C22N-H 123.221 8.445

Search for: 0/102 (102)

Update | save.. | options.. | Close | Help

I~ Volume error [~ Assignment distance
[~ Transpose volume [ Mardigras format
I Fit residual I” Dyana format
I~ Fit height I Note
Sortby: Resonance name —
Sort axis: [1
" Pair crossdiagonal peaks?

X| Pointef Format:
« select

Coenter | ok ‘ Apply | Close \M
21. The peak list should now be populated with an additional column containing the calculated
volume for a given peak:

343. X/ Options Spectrum Peaks Nb6_nh.
saseline offset 8.6] v Assignment. [~ Data height
[~ User label [ signal / Noise
B W Frequency (ppm) [ Linewidth
. =" I~ Frequency (Hz) I~ Freq of resonance axis
ussian-to-Voigt m| - ot I Dev of .
M Apply | cl ¥ Volume [~ Spectrum Name

[ BN ] X Spectrum Peaks Nb6_nhsqc
Assignment wl w2 Volume
L1IN-H 122.672 8.053 1.08e+13 ga =
V12N-H 124.134 8.902 8.58e+12 ga J
Q13N-H 122.731 8.197 1.17e+13 ga
Al4N-H 124.016 8.016 8.23e+12 ga
G15N-H 112.982 9.632 6.90e+12 ga
G16N-H 109.147 8.382 1.11e+13 ga
S17N-H 109.773 7.811 1.38e+13 ga
L18N-H 124.783 TeEER 2.49e+12 ga
R19N-H 122.241 9.563 5.20e+12 ga
L206N-H 125.958 8.709 5.64e+12 ga
S21N-H 125.645 7.832 1.70e+13 ga /|
Search for: 0/102 (102)
Update ‘ Save... ‘ Options... ‘ Close ‘ Help [

Click Save to write the peak list. As is the case for moving peaks, any time you re-integrate a
peak, be sure to click Update and re-save the list.

At this point, you can closely examine the spectra for Nb6 and mNb6 in complex with the Spike
RBD.



